Gynzy Kids niet bereikbaar
Incident Report for Gynzy
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 10, 2018 - 11:44 CET
Monitoring
Gynzy Kids is weer bereikbaar.
Posted 10 months ago. Jan 10, 2018 - 10:33 CET
Investigating
Gynzy Kids is tijdelijk niet bereikbaar.
Posted 10 months ago. Jan 10, 2018 - 09:38 CET